通达信KDJ金叉死叉背离副图指标源公式源码

[复制链接]
查看116 | 回复0 | 2021-8-28 00:48:30 | 显示全部楼层 |阅读模式

以下是通达信KDJ金叉死叉背离副图指标源公式源码(无源码的请下载附件导入)

DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);
STICKLINE(C>0,120,120,28,-1)COLORBLACK;
STICKLINE(C>0,100,100,28,-1)COLOR000080;
STICKLINE(C>0,80,80,28,-1)COLOR000080;
STICKLINE(C>0,50,50,28,-1)COLOR000080;
STICKLINE(C>0,20,20,28,-1)COLOR000080;
STICKLINE(C>0,0,0,28,-1)COLOR000080;
STICKLINE(C>0,-20,-20,28,-1)COLORBLACK;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1)COLORCYAN;
D:SMA(K,3,1)COLORYELLOW;
J:3*K-2*D,COLORMAGENTA;

{以下是金叉死叉背离}
{}
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);
DRAWTEXT((B2>0),-10,'_金叉底背'),COLORLIRED;
STICKLINE((B2>0),-10,50,0,-1)COLORLIRED;
{DRAWLINE((B2>0),K,B2,K,0),COLORLIRED,DOTLINE;}{金叉底背画线};
{}
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);
DRAWTEXT((D2>0),110,'_死叉顶背'),COLORLICYAN;
STICKLINE((D2>0),110,50,0,-1)COLORLICYAN;
{DRAWLINE((D2>0),K,D2,K,0),COLORGREEN,DOTLINE;}{死叉顶背画线};

142355285.png

142355285.png

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则