通达信版本分享一个益盟操盘手的经典指标黄金回踩指标

[复制链接]
查看438 | 回复0 | 2021-8-28 00:58:27 | 显示全部楼层 |阅读模式

以下是通达信版本分享一个益盟操盘手的经典指标黄金回踩指标(无源码的请下载附件导入)

分享一个益盟操盘手的经典指标黄金回踩指标【通达信版本】在论坛朋友的指标基础上修改,不加密,无未来函数,完全高度还原了益盟黄金回踩指标,非常好用!

M:=20;
XA_1:=MA(C,5);
XA_2:=MA(C,10);
XA_3:=MA(C,30);
XA_4:=SMA(MAX(CLOSE-REF(CLOSE,1),0),17,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),17,1)*100;
XA_5:=BARSLAST(CROSS(XA_1,XA_2));
XA_6:=BARSLAST(CROSS(XA_1,XA_3));
XA_7:=BARSLAST(CROSS(XA_2,XA_3));
XA_8:=XA_5>=XA_6 AND XA_6>XA_7 AND XA_5-XA_7<M;
XA_9:=COUNT(CROSS(XA_1,XA_2),XA_5+1)=1 AND COUNT(CROSS(XA_1,XA_3),XA_5+1)=1 AND CROSS(XA_2,XA_3) AND XA_1>XA_2 AND XA_2>XA_3;
XA_10:=XA_8 AND XA_9;
触发:XA_8 AND XA_9,NODRAW,COLORCCCCCC;
XA_11:=COUNT(触发,BARSLAST(触发)+1)=1 AND COUNT(CROSS(XA_3,XA_1),BARSLAST(触发)+1)=0;
回踩:LOW<=XA_3 AND CLOSE>XA_3 AND XA_11 AND BARSLAST(触发)>0,NODRAW,COLORMAGENTA;
XA_12:=COUNT(触发,BARSLAST(触发)+1)=1 AND CROSS(XA_3,XA_1) AND COUNT(CROSS(XA_3,XA_1),BARSLAST(触发)+1)=1;
破坏:XA_12>0,NODRAW,COLORBLUE;
区间:COUNT(触发,BARSLAST(触发)+1)=1 AND COUNT(破坏,BARSLAST(触发)+1)=0,NODRAW,COLOR696960;
STICKLINE(区间>0,0,70,4,0),COLOR696969;
STICKLINE(破坏>0,0,70,4,0),COLORBLUE;
DRAWTEXT(破坏,10,'---破坏'),COLORBLUE;
STICKLINE(回踩>0,0,70,4,0),COLORMAGENTA;
DRAWTEXT(回踩,35,'---回踩'),COLORMAGENTA;
STICKLINE(触发>0,0,70,4,0),COLORWHITE;
DRAWTEXT(触发,60,'---触发'),COLORWHITE;

14499577.jpg

14499577.jpg

144177669.jpg

144177669.jpg

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则