通达信手机分时T+0主图源码

[复制链接]
查看604 | 回复0 | 2021-8-20 03:43:09 | 显示全部楼层 |阅读模式

以下是通达信手机分时T+0主图源码(无源码的请下载附件导入)

乘周末有空把“T+0分时主图”适当简化一下,用于手机通达信上(也可以用于电脑)。考虑到手机内存关系,把可以精简的都去掉,能显示关键的就行,由于手机通达信软件还不完善,买卖盘彩条不能显示,如这一项不要的可以去掉:源码中空行一下的{买卖盘彩条}源码删掉即可。希望能对朋友们有帮助。
MA30:=EMA(CLOSE,30);
强弱:EMA(CLOSE,900);
STICKLINE((MA30>强弱),MA30,强弱,0.1,0),COLORRED;
STICKLINE((MA30<强弱),MA30,强弱,0.1,0),COLORGREEN;
DRAWTEXT(ISLASTBAR AND C,C,STRCAT('←',CON2STR(C,2))),COLORYELLOW;
均价:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK2;
CZ:=BARSCOUNT(C);前高:=REF(HHV(H,CZ),1);
突破:=CROSS(C,REF(HHV(H,CZ),1)) AND C/均价<1.09 AND CZ>1 AND CZ<240;
DRAWTEXT(CROSS(C,REF(HHV(H,CZ),1)) AND C/均价<1.09 AND CZ>=1 AND CZ<240,前高,'突'),COLORMAGENTA;
主扫:=COUNT(突破,13)>=3 AND CROSS(C,REF(HHV(H,CZ),1));
DRAWTEXT(主扫,前高, '←扫盘'),COLORYELLOW;
全买:=CROSS(C,REF(HHV(H,CZ),1)) AND HHVBARS(VOL,CZ)=0 AND C/均价<1.09 AND CZ>1 AND CZ<240 AND BARSLAST(主扫)>=21;DRAWTEXT(全买 ,前高, '←全仓'),COLORCYAN;
VAR1:=EMA(EMA(C,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;JJ:=DYNAINFO(11);
能量:=(EMA(C,8)-EMA(C,55))*10;空头:=EMA(能量,3);
TJ1:=(C-JJ)/JJ<-0.03;
TJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;TJ3:=CROSS(能量,空头) AND 能量<-0.3;TJ4:=FILTER(TJ1 AND TJ2 AND TJ3,13);
DRAWTEXT(TJ4,C*0.999,'←有庄'),COLORRED;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;阻:L1+P1*7/8,COLORGREEN;
撑:L1+P1*0.5/8,COLORMAGENTA;中:(撑+阻)/2,COLORWHITE,POINTDOT;
DRAWICON(LONGCROSS(撑,C,2),C,34);
DRAWICON(LONGCROSS(C,阻,2),C,35);
STICKLINE(LONGCROSS(撑,C,2),撑,中,1,0),COLORCC00FF;
STICKLINE(LONGCROSS(C,阻,2),阻,中,1,0),COLOR33FF33;
底买:STICKLINE(C<撑,撑,C,2,0),COLORRED;
STICKLINE(LONGCROSS(撑,C,2),撑,(撑-中)/5+撑,2,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(撑,C,2),(撑-中)/5+撑,'底'),COLORYELLOW;
STICKLINE(LONGCROSS(C,阻,2),阻,阻-(撑-中)/5,2,0),COLORLIRED;
DRAWTEXT(LONGCROSS(C,阻,2),阻-(撑-中)/5,'顶'),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=8,阻+0.003,'顶'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=8,撑-0.003,'底'),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=8,(撑+阻)/2,'中'),COLORWHITE;
顶:HHV(H,480),COLORRED,DOTLINE;
底:LLV(L,480),COLORGREEN,DOTLINE;
DRAWNUMBER(FILTER(CROSS(C,DYNAINFO(3)*1.1-0.01),60),C*0.99,TIME);
DRAWNUMBER(FILTER(CROSS(C,DYNAINFO(3)*1.1-0.01),60),C*0.98,C),COLORYELLOW;
DRAWTEXT_FIX(1,0.1,0.88,0,'市盈率:'),COLORLIBLUE;
DRAWNUMBER_FIX(1,0.2,0.88,0,CONST(DYNAINFO(39))),COLORLIBLUE;
DRAWTEXT_FIX(1,0.1,0.98,0,'市净率:'),COLORCYAN;
DRAWNUMBER_FIX(1,0.18,0.98,0,CONST(C/FINANCE(34))),COLORCYAN;

{买卖盘彩条}
成交额:=V*C/100;
AE2:=SUM((IF(((成交额/8>20) AND(CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
AE3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
AE6:=(AE2+AE3);DD1:=1;
A3:=STRCAT(STRCAT('机构净入',CON2STR((100*(AE2-AE3))/AE6,0)),'%');
DRAWTEXT_FIX(DD1=1,0.33,1,0,A3),COLORLIRED;
XSB:BUYVOL*DYNAINFO(7)*100/10000,COLOR0000FF,NODRAW;
XSS:SELLVOL*DYNAINFO(7)*100/10000 COLOR00FF00,NODRAW;
合:=ABS(XSB)+ABS(XSS),COLOR80FFFF;
差:=ABS(XSB)-ABS(XSS),COLOR80FFFF;
PB1:=ABS(XSB)/合*100;
PB2:=ABS(XSS)/合*100;
TESTSKIP(NOT(XSB OR XSS OR 合 OR 差 OR PB1 OR PB2)!=0);
DRAWRECTREL(595,1000,795,935,RGB(0,228,0));
DRAWRECTREL(595,1000,595+XSB*200/合,940,RGB(228,0,0));
DRAWRECTREL(595+XSB*200/合,940,595+XSB*200/合,1000,RGB(228,0,0));
DRAWRECTREL(795,939,795,1000,RGB(0,0,10));
DRAWRECTREL(695,940,695,1000,RGB(255,255,0));
DRAWRECTREL(595,939,595,1000,RGB(0,0,10));
DRAWRECTREL(595,939,795,939,RGB(0,0,10));
DRAWTEXT_FIX(1,0.5,0.84,0,STRCAT(STRCAT('',CON2STR(XSB,1)),'万')),COLOR0000FF;
DRAWTEXT_FIX(1,0.87,0.84,0,STRCAT(STRCAT('',CON2STR(XSS,1)),'万')),COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (差)>0,0.67,0.84,0,STRCAT('  ',STRCAT(CON2STR(差,1),'万')))COLOR0000FF;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (差)<0,0.67,0.84,0,STRCAT('  ',STRCAT(CON2STR(差,1),'万')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (差)=0,0.67,0.83,0,STRCAT('  ',STRCAT(CON2STR(差,1),'万')))COLOR80FFFF;
DRAWTEXT_FIX(1,0.85,0.98,0,STRCAT(STRCAT('',CON2STR(PB2,1)),'%')),COLOR00FF00;
DRAWTEXT_FIX(1,0.5,0.98,0,STRCAT(STRCAT('',CON2STR(PB1,1)),'%')),COLOR0000FF;

644422509.jpg

644422509.jpg

644488397.png

644488397.png

644544997.jpg

644544997.jpg


 

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则