通达信资金副图源码

[复制链接]
查看167 | 回复0 | 2021-8-20 15:40:56 | 显示全部楼层 |阅读模式

以下是通达信资金副图源码(无源码的请下载附件导入)

{量能饱和度}
DRAWGBK(CURRBARSCOUNT=1, RGB(110,108,108),RGB(88,30,0),0,'',0);
 M:=1.2;
 N1:=34;
 N2:=N1*1.05;
 N3:=N1+3;
 SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:IF(SAT>1,1,SAT)*100,COLORLIBLUE,NODRAW;
中点:=REFDATE(HHV(V,100)/2,DATE);{量能饱和的变色切换}
STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00DDDD;
 STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和度,0),COLOR0033FF;
 STICKLINE(CURRBARSCOUNT=N1,中点*1.82,中点*1.58,量能饱和度,0),COLOR0077FF;
 STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,量能饱和度,0),COLOR0099FF;
 STICKLINE(CURRBARSCOUNT=N1,中点*1.7,中点*1.7,量能饱和度,0),COLORFFDD55;
 DRAWTEXT(CURRBARSCOUNT=N3,中点*1.82,'量能饱和度'),COLORBLUE;
 VOLUME:VOL,VOLSTICK;
 {主力量能}
SHORT:=12;
 LONG:=26;
 MID:=9;
 DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
 DEA:=EMA(DIF,MID);
 MACD:=(DIF-DEA)*2,COLORSTICK;
 STICKLINE(DIF>DEA,0,VOL,3,0),COLORRED;
 STICKLINE(DIF<DEA,0,VOL,3,0),COLORGREEN;
 N:=9;
 M1:=3;
 M2:=3;
 RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
 K:=SMA(RSV,M1,1);
 D:=SMA(K,M2,1);
 J:=3*K-2*D;
 STICKLINE(J>D,VOL/2,VOL,3,0),COLORRED;
 STICKLINE(J<D,VOL/2,VOL,3,0),COLORGREEN;
 {量能潮}
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
 OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
 OBV2:=EMA(OBV1,3)-MA(OBV1,9);
 OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
 MAC3:=MA(C,3);
限制:=IF(OBV3>=VOL,VOL,IF(OBV3<VOL,OBV3,0));
 STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,限制,2,0),COLORYELLOW;
 {量:=V,VOLSTICK;}
 PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
 JJ:=REF(EMA(PJJ,3),1);
 QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)))); XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN)
 ,(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
 ZLL:=(VOL / CAPITAL);
 HSL1:=IF((ZLL > 10),10,ZLL);
 HSL:=((XVL / 20) / 1.15);
进攻流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
 GJJ:=EMA(进攻流量,8); LLJX:=EMA(进攻流量,3);
动态天量:=CONST(IF(V=HHV(V,N),V,REF(V,BARSLAST(V=HHV(V,N))))),COLOR00FF00,POINTDOT;
 STICKLINE(((HSL * 0.4) >= 0),动态天量*M+((HSL * 0.4) +LLJX)*20,动态天量*M,3,0),COLORYELLOW;
 STICKLINE(((HSL * 0.4) < 0),动态天量*M+((HSL * 0.4) +LLJX)*20,动态天量*M,3,0),COLOR00FF00;
资金流入:=IF((HSL*0.4+LLJX)>0,(HSL*0.4+LLJX),DRAWNULL),COLORRED;
资金流出:=IF((HSL*0.4+LLJX)<0,(HSL*0.4+LLJX),DRAWNULL),COLOR00FF00;
资金收支:=(HSL*0.4+LLJX),LINETHICK0;
万元:=AMOUNT/10000{0000},VOLSTICK,COLORFF00FF;
资金净收支:IF((HSL*0.4+LLJX)>0,资金流入,资金流出),COLORWHITE,POINTDOT;
收支比例%:IF((HSL*0.4+LLJX)>0,资金流入/万元*100,资金流出/万元*100),COLORYELLOW;
连红天1:=BARSLASTCOUNT(资金净收支>0),,COLORA20FFD,NODRAW;
连红天2:=IF(连红天1=0,REF(连红天1,1),连红天1),,COLORA20FFD,NODRAW;
连红天3:=IF(连红天2=0,REF(连红天1,2),连红天2),,COLORA20FFD,NODRAW;
连红天4:=IF(连红天3=0,REF(连红天1,3),连红天3),,COLORA20FFD,NODRAW;
近期连红天:IF(连红天4=0,REF(连红天1,4),连红天4),,COLORYELLOW,NODRAW;
三日资金:SUM(资金收支,3),COLORWHITE,NODRAW;
五日资金:SUM(资金收支,5),COLORFF00FF,NODRAW;
十日资金:SUM(资金收支,10),COLOR0000FF,NODRAW;
资金流量:=LLJX,LINETHICK0,COLOR0000FF;
 STICKLINE((资金流量 > 0),动态天量*M+资金流量*20,动态天量*M,3,0),COLOR0000FF;
 STICKLINE((资金流量 < 0),动态天量*M+资金流量*20,动态天量*M,3,0),COLOR008000;
 {135均线}
MAVOL5:MA(VOLUME,5),LINETHICK1,COLORFFFFFF;
资金异动135:MA(VOLUME,135),LINETHICK2,COLORFF80FF;
主力洗盘35:MA(VOL,35),LINETHICK2,COLORFFFF80;
 TT:=240/FROMOPEN;
比:=TT;
 AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);
 AZ2:=EMA(AY2,9);
 LT2:=(AY2-AZ2);
 L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;
 ZGD:=HHV(H,80)*0.99;
 ZGD2:=CONST(ZGD);
 ZDD:=LLV(L211,80);
 ZDD2:=CONST(ZDD);
 YYA4:=MA(CLOSE,20);
 YYA5:=(CLOSE > MA(CLOSE,5));
 YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));
 YYA7:=(CLOSE > MA(CLOSE,10));
 YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));
 YYA9:=(CLOSE > MA(CLOSE,20));
 YYA10:=REF(YYA4,1);
 YYA11:=(YYA4 > YYA10);
 YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));
 DSLX:=(CLOSE / INDEXC);
 DSLX1:=MA(DSLX,5);
 DSLX2:=MA(DSLX,10);
 YYV1:=MA(VOL,5);
 YYV2:=MA(VOL,10);
 J1:=CONST(IF( YYAVX > 0,200,100));
 J2:=CONST(IF( YYAVX > 0,00,100));
 J3:=CONST(IF( YYAVX > 0,100,100));
 ZGD3:=ZGD2;
 ZDD3:=ZDD2;
 ZGD4:=ZGD2;
情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)),NODRAW;
情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));
情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));
情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;
情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));
大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));
大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));
大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));
大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));
大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));
大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));
大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));
 MFI:=(HIGH-LOW)*1000000/(VOL*比);
绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);
 MMM1:=CONST(绿灯);
衰退:=MFI<REF(MFI,1)AND VOL*比<REF(VOL,1);
 MMM2:=CONST(衰退);
伪装:=MFI>=REF(MFI,1)AND VOL*比<REF(VOL,1);
 MMM3:=CONST(伪装);
蛰伏:=MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1);
 MMM4:=CONST(蛰伏);
WJ:=(H+L+C)/3;
 V1:=IF(H=L,1,H-MAX(O,C));
 V2:=IF(H=L,1,MAX(C,O)-WJ);
 V3:=IF(H=L,1,MIN(O,C)-L);
 V4:=IF(H=L,1,WJ-MIN(C,O));
 V5:=VOL/IF(H=L,4,H-L);
 V6:=(V1*V5);
 V7:=(V2*V5);
 V8:=(V3*V5);
 V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);
 {买卖差:=买盘-卖盘;}
量大:=(卖盘+买盘)/REF(VOL,1)>2;
 MMM5:=CONST(量大);
量缩:=REF(VOL,1)/(卖盘+买盘)>1.5;
 MMM6:=CONST(量缩);
卖量大:=(卖盘-买盘)/买盘>0.4;
 MMM7:=CONST(卖量大);
买量大:=(买盘-卖盘)/卖盘>0.4;
 MMM8:=CONST(买量大);
TS1:=IF(情况1=1,0.06+0.06,0.06); TS2:=IF(情况2=1,TS1+0.06,TS1);
 TS3:=IF(情况3=1,TS2+0.06,TS2); TS4:=IF(情况4=1,TS3+0.06,TS3);
 TS5:=IF(情况5=1,TS4+0.06,TS4); TS6:=IF(情况6=1,TS5+0.06,TS5);
 TS7:=IF(情况7=1,TS6+0.06,TS6); TS8:=IF(情况8=1,TS7+0.06,TS7);
 TS9:=IF(情况9=1,TS8+0.06,TS8); TS10:=IF(情况10=1,TS9+0.06,TS9);
 TS11:=IF(情况11=1,TS10+0.06,TS10); TS12:=IF(情况12=1,TS11+0.06,TS11);
 TS13:=IF(情况13=1,TS12+0.06,TS12); TS14:=IF(情况14=1,TS13+0.06,TS13);
 TS15:=IF(情况15=1,TS14+0.06,TS14); TS16:=IF(情况16=1,TS15+0.06,TS15);
 TS17:=IF(大盘1=1,TS16+0.06,TS16); TS18:=IF(大盘2=1,TS17+0.06,TS17);
 TS19:=IF(大盘3=1,TS18+0.06,TS18); TS20:=IF(大盘4=1,TS19+0.06,TS19);
 TS21:=IF(大盘5=1,TS20+0.06,TS20); TS22:=IF(大盘6=1,TS21+0.06,TS21);
 TS23:=IF(大盘7=1,TS22+0.06,TS22); TS24:=IF(大盘8=1,TS23+0.06,TS23);
 TS25:=IF(MMM1=1,TS24+0.06,TS24);
 TS26:=IF(MMM2=1,TS25+0.06,TS25);
 TS27:=IF(MMM3=1,TS26+0.06,TS26);
 TS28:=IF(MMM4=1,TS27+0.06,TS27);
 TS29:=IF(MMM5=1,TS28+0.03,TS28);
 TS30:=IF(MMM6=1,TS29+0.03,TS29);
 TS31:=IF(MMM7=1,TS30+0.03,TS30);
 TS32:=IF(MMM8=1,TS31+0.03,TS31);
 DRAWTEXT_FIX(情况1=1 ,0.10,0,0,'量能理想,明显走强,中线参与,仓位控制在70%左右。'),COLORFF00FF;
 DRAWTEXT_FIX(情况2=1 ,0.10,0,0,'走势趋强,量能不足,短线进场,仓位控制在50%左右。'),COLORFF00FF;
 DRAWTEXT_FIX(情况3=1 ,0.10,0,0,'量价良好,并无明显走强,短线可进场,仓位50%左右。'),COLORFF00FF;
 DRAWTEXT_FIX(情况4=1 ,0.10,0,0,'形态尚可,量能不足,未全走强,短入,仓位30%左右。'),COLORFF00FF;
 DRAWTEXT_FIX(情况5=1 ,0.10,0,0,'形态已变坏,走势尚可,重仓者减大半,清仓者%观望。'),COLOR00FFFF;
 DRAWTEXT_FIX(情况6=1 ,0.10,0,0,'随大盘下跌,明显缩量,考虑大盘风险,减持或清仓。'),COLOR00FFFF;
 DRAWTEXT_FIX(情况7=1 ,0.10,0,0,'该股放量下跌,走势明显偏弱,不抢反弹,离场观望。'),COLORFFFFFF;
 DRAWTEXT_FIX(情况8=1 ,0.10,0,0,'该股缩量下跌,走势偏弱无力,人气散失,离场观望。'),COLORFFFF00;
 DRAWTEXT_FIX(情况9=1 ,0.10,0,0,'该股形态良好,强势明显,量能充足,可以继续持有。'),COLOR00FFFF;
 DRAWTEXT_FIX(情况10=1,0.10,0,0,'上行趋势不变,强势依然,量能开始转弱,注意风险。'),COLOR00FFFF;
 DRAWTEXT_FIX(情况11=1,0.10,0,0,'该股仍然具备上涨潜力,但股性偏弱,可以考虑减仓。'),COLORFFFFFF;
 DRAWTEXT_FIX(情况12=1,0.10,0,0,'该股走势趋弱,量能明显不足,减大部分筹码或空仓。'),COLORFFFF00;
 DRAWTEXT_FIX(情况13=1,0.10,0,0,'该股形态不佳,注意成交量变化,但目前不适合参与。'),COLORFFFF00;
 DRAWTEXT_FIX(情况14=1,0.10,0,0,'该股趋势不明,股价偏弱,注意量能变化,暂不参与。'),COLORFFFF00;
 DRAWTEXT_FIX(情况15=1,0.10,0,0,'有走强迹象,但量能不足,趋势不明朗,不适合操作。'),COLORFFFF00;
 DRAWTEXT_FIX(情况16=1,0.10,0,0,'该股走势太弱,主动性买盘弱,没有太大的参与价值。'),COLORFFFFFF;
 DRAWTEXT_FIX(大盘1,0.10,0.05,0,'总势量能理想,70%仓位, 若最佳买点,否则谨慎介入。'),COLOR00FF00;
 DRAWTEXT_FIX(大盘2,0.10,0.05,0,'总势趋强,量不足,若前轮下跌,短进50%,量大加仓。'),COLORFF00FF;
 DRAWTEXT_FIX(大盘3,0.10,0.05,0,'总势形态走坏,重仓者可减去大部分仓位或放空筹码。'),COLORAAAAAA;
 DRAWTEXT_FIX(大盘4,0.10,0.05,0,'总势缩量调整,注意大盘系统风险,短线可清仓观望。'),COLORFFFFFF;
 DRAWTEXT_FIX(大盘5,0.10,0.05,0,'总势走势良好,量能理想,可继续持有或加仓强势股。'),COLOR00FFFF;
 DRAWTEXT_FIX(大盘6,0.10,0.05,0,'总势形态良好,但量能稍显不足,随时准备减仓调仓。'),COLOR00FF00;
 DRAWTEXT_FIX(大盘7,0.10,0.05,0,'总势趋势不明,注意成交量变化,目前暂不适宜进场。'),COLORFFFFFF;
 DRAWTEXT_FIX(大盘8,0.10,0.05,0,'总势趋势向下,量能萎缩,短线可杀跌,不适合进场。'),COLORFFFFFF;
 DRAWTEXT_FIX(MMM1,0.10,0.10,0,'[绿灯]实计交易量增加。MFI促进指数增加。'),COLORFFFFFF;
 DRAWTEXT_FIX(MMM2,0.10,0.10,0,'[衰退]实计交易量减少。MFI促进指数减少。'),COLORGREEN;
 DRAWTEXT_FIX(MMM3,0.10,0.10,0,'[伪装]实计交易量减少。MFI促进指数增加。'),COLORGREEN;
 DRAWTEXT_FIX(MMM4,0.10,0.10,0,'[蛰伏]实计交易量增加。MFI促进指数减少。'),COLORYELLOW;
 DRAWTEXT_FIX(MMM5,0.10,0.15,0,'★今天比昨天的成交量放大一倍以上。'),COLORGREEN;
 DRAWTEXT_FIX(MMM6,0.10,0.15,0,'★今天比昨天的成交量缩量一半以上。'),COLORYELLOW;
 DRAWTEXT_FIX(MMM7,0.10,0.20,0,'☆该股今天卖出量大于买入量40%以上。'),COLORGREEN;
 DRAWTEXT_FIX(MMM8,0.10,0.20,0,'☆该股今天买入量大于卖出量40%以上。'),COLORYELLOW;

712533189.jpg

712533189.jpg

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则