通达信趋势+资金+最佳介入点源码副图

[复制链接]
查看269 | 回复0 | 2021-8-20 20:17:30 | 显示全部楼层 |阅读模式

以下是通达信趋势+资金+最佳介入点源码副图(无源码的请下载附件导入)

V1:=MA(C,3)=HHV(MA(C,3),7);
 V2:=MA(C,3)>MA(C,5);
 V3:=MA(V,5)>MA(V,10)*1.01;
 V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
 LC20:=REF(CLOSE,1);
 RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100;
 STICKLINE(CROSS(RSI20,11)*1,-10,20,2,0),COLORYELLOW;
 VAR3A:=3;
 VAR2A:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
 MTM:=C-REF(C,1);
 DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
 YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:IF(FILTER(YXF=1,5),20,-10),STICK,COLORBLUE,LINETHICK3;
 A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV
 (L,55))*100,5,1);
 FY:=EMA(A51,5);
 A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
 QS:(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2)),LINETHICK2,COLORRED;

HLM1:=MA(HHV(H,485),17);
 HLM2:=MA(HHV(H,222),17);
 HLM3:=MA(HHV(H,96),17);
 HLM4:=MA(LLV(L,485),17);
 HLM5:=MA(LLV(L,222),17);
 HLM6:=MA(LLV(L,96),17);
 HLM7:=MA((HLM1*0.558+HLM2*0.558+HLM3*0.558+HLM4*0.96+HLM5*0.96+HLM6*0.96)/6,17);
 HLM8:=MA((HLM1*0.55+HLM2*0.55+HLM3*0.65+HLM4*1.25+HLM5*1.23+HLM6*1.2)/6,17);
 HLM9:=MA((HLM1*0.68+HLM2*0.68+HLM3*0.68+HLM4*1.3+HLM5*1.3+HLM6*1.3)/6,17);
 HLM10:=MA((HLM7*3+HLM8*2+HLM9)/6*1.738,17);
 HLM11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
 HLM12:=MA(IF(C*1.35<=HLM10,HLM11*10,HLM11/10),3);
 HLMH:=HHV(HLM12,30);
关注:MA(IF(L<=LLV(L,13),(HLMH+HLM11*2)/2,0),3)/200,COLORFFFFFF;
 DRAWTEXT(CROSS(关注,1.2),关注*0.5-6,'↑▲'),COLORFF00FF;
 DRAWTEXT(CROSS(关注,4.5),关注,'买点出现'),COLOR00FFFF;
 DRAWICON(CROSS(关注,7.0),关注*0.5-20,14);

VAR1:=EMA(HHV(HIGH,500),21);
 VAR2:=EMA(HHV(HIGH,250),21);
 VAR3:=EMA(HHV(HIGH,90),21);
 VAR4:=EMA(LLV(LOW,500),21);
 VAR5:=EMA(LLV(LOW,250),21);
 VAR6:=EMA(LLV(LOW,90),21);
 VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
 VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
 VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
 VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
 VARB:=REF(LOW,1);
 VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
 VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
 VARE:=LLV(LOW,30);
 VARF:=HHV(VARD,30);
 VAR10:=IF(MA(CLOSE,58),1,0);
资金入场: EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;
资金进场: IF(资金入场>0,资金入场,0),STICK,LINETHICK2, COLOR0000FF;
今量: 资金进场;
A1:IF(资金进场>0,今量*6,0),STICK,LINETHICK5, COLOR0000FF;
 A2:IF(资金进场>0,今量*4,0),STICK,LINETHICK5, COLOR0066FF;
 A3:IF(资金进场>0,今量*3,0),STICK,LINETHICK5, COLOR0099FF;
 A4:IF(资金进场>0,今量*2,0) ,STICK,LINETHICK5,COLOR00CCFF;
 A5:IF(资金进场>0,今量*1,0) ,STICK,LINETHICK5,COLOR00FFFF;

712333349.jpg

712333349.jpg

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则