同花顺周线走好 修改版

[复制链接]
查看328 | 回复0 | 2021-8-21 02:11:35 | 显示全部楼层 |阅读模式

以下是同花顺周线走好 修改版(无源码的请下载附件导入)

T:=BARSLAST(WEEKOFYEAR!=REF(WEEKOFYEAR,1));
 C1:=REF(C,T+1);
 C2:=REF(C1,T+1);
 C3:=REF(C2,T+1);
 C4:=REF(C3,T+1);
 C5:=REF(C4,T+1);
 C6:=REF(C5,T+1);
 C7:=REF(C6,T+1);
 C8:=REF(C7,T+1);
 C9:=REF(C8,T+1);
 M10:=(C+C1+C2+C3+C4+C5+C6+C7+C8+C9)/10;
 E20:EXPMA(C,20);
 E120:EXPMA(C,120);
 E250:EXPMA(C,250);
 A:=MACD.DIF;
 B:=MACD.DEA;
 T1:=BARSLAST(CROSS(A,B));
 ST:=BARSLAST(CROSS(B,A));
 ZF:=(HHV(H,110)-LLV(L,110))/LLV(L,110)*100;
 TJ:=EVERY(V>REF(V,1),2);
 HH:=MAX(MAX(E20,E120),E250);
 LL:=MIN(MIN(E20,E120),E250);
 NH:=HH/LL*100-100;
 TJ1:=EVERY(NH<40,25);
 ZZF:=(C-REF(C,10))/REF(C,10)*100 ;
 TJA:=C>M10;
 XG:=T1=0 AND A<REF(A,ST) AND B<REF(B,ST) AND ZF<70 AND TJ AND TJ1 AND ZZF<1.4 AND TJA;
 STICKLINE(XG,C,O,2,0),COLORYELLOW;
 STICKLINE(XG,H,L,0,0),COLORYELLOW;
 DRAWTEXT(XG,L*0.98,'周线走好'),COLORYELLOW;

选股


T:=BARSLAST(WEEKOFYEAR!=REF(WEEKOFYEAR,1));
 C1:=REF(C,T+1);
 C2:=REF(C1,T+1);
 C3:=REF(C2,T+1);
 C4:=REF(C3,T+1);
 C5:=REF(C4,T+1);
 C6:=REF(C5,T+1);
 C7:=REF(C6,T+1);
 C8:=REF(C7,T+1);
 C9:=REF(C8,T+1);
 M10:=(C+C1+C2+C3+C4+C5+C6+C7+C8+C9)/10;
 E20:=EXPMA(C,20);
 E120:=EXPMA(C,120);
 E250:=EXPMA(C,250);
 A:=MACD.DIF;
 B:=MACD.DEA;
 T1:=BARSLAST(CROSS(A,B));
 ST:=BARSLAST(CROSS(B,A));
 ZF:=(HHV(H,110)-LLV(L,110))/LLV(L,110)*100;
 TJ:=EVERY(V>REF(V,1),2);
 HH:=MAX(MAX(E20,E120),E250);
 LL:=MIN(MIN(E20,E120),E250);
 NH:=HH/LL*100-100;
 TJ1:=EVERY(NH<40,25);
 ZZF:=(C-REF(C,10))/REF(C,10)*100 ;
 TJA:=C>M10;
 XG:T1=0 AND A<REF(A,ST) AND B<REF(B,ST) AND ZF<70 AND TJ AND TJ1 AND ZZF<1.4 AND TJA;


幅图信号标注

T:=BARSLAST(WEEKOFYEAR!=REF(WEEKOFYEAR,1));
 C1:=REF(C,T+1);
 C2:=REF(C1,T+1);
 C3:=REF(C2,T+1);
 C4:=REF(C3,T+1);
 C5:=REF(C4,T+1);
 C6:=REF(C5,T+1);
 C7:=REF(C6,T+1);
 C8:=REF(C7,T+1);
 C9:=REF(C8,T+1);
 M10:=(C+C1+C2+C3+C4+C5+C6+C7+C8+C9)/10;
 E20:=EXPMA(C,20);
 E120:=EXPMA(C,120);
 E250:=EXPMA(C,250);
 A:=MACD.DIF;
 B:=MACD.DEA;
 T1:=BARSLAST(CROSS(A,B));
 ST:=BARSLAST(CROSS(B,A));
 ZF:=(HHV(H,110)-LLV(L,110))/LLV(L,110)*100;
 TJ:=EVERY(V>REF(V,1),2);
 HH:=MAX(MAX(E20,E120),E250);
 LL:=MIN(MIN(E20,E120),E250);
 NH:=HH/LL*100-100;
 TJ1:=EVERY(NH<40,25);
 ZZF:=(C-REF(C,10))/REF(C,10)*100 ;
 TJA:=C>M10;
 XG:=T1=0 AND A<REF(A,ST) AND B<REF(B,ST) AND ZF<70 AND TJ AND TJ1 AND ZZF<1.4 AND TJA;
 STICKLINE(XG,0,8,2,0),COLORYELLOW;

656111677.jpg

656111677.jpg

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则