同花顺神奇抄底副图指标

[复制链接]
查看295 | 回复0 | 2021-8-21 04:19:13 | 显示全部楼层 |阅读模式

以下是同花顺神奇抄底副图指标(无源码的请下载附件导入)

同花顺神奇抄底副图指标

源码

红柱:IF("MACD.MACD">REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),
 STICK,COLORRED;
绿柱:IF("MACD.MACD"<REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),
 STICK,COLORYELLOW;
 _抄底:ABS((CROSS("MACD.DIF","MACD.DEA")
 &&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.50,COLORLIMAGENTA;
 _DIF:"MACD.DIF",COLORWHITE;
 _DEA:"MACD.DEA",COLORYELLOW;
 __强度:IF(_DIF>_DEA,_DIF,DRAWNULL),COLORRED,LINETHICK2;
 _强度:IF(_DEA<_DIF,_DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
 DRAWTEXT(ABS(_抄底)>0,_抄底*1.20,' 抄底'),COLORYELLOW;
 DRAWICON(ABS(_抄底)>0,_抄底*1.10,4);
 DRAWICON(CROSS(_DIF,_DEA),_DEA,1);
 DRAWICON(CROSS(_DEA,_DIF),_DEA,2);

DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
 DEA:EMA(DIFF,9);
 MACD:2*(DIFF-DEA),COLORSTICK;
 A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
 B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
 A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
 B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
 A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
 B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
 C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
 D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
 C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
 D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
 C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
 D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
 MD底背:IF(B1>0,-0.1,0),COLORRED,POINTDOT;
 KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;
 RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;
 MD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;
 KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;
 RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;
 STICKLINE(B1>0,-0.1,0,2,0),COLORRED;
 STICKLINE(B2>0,-0.1,0,2,0),COLORFF00FF;
 STICKLINE(B3>0,-0.1,0,2,0),COLORYELLOW;
 STICKLINE(D1>0,0.1,0,2,0),COLOR00FF00;
 STICKLINE(D2>0,0.1,0,2,0),COLORFFCC66;
 STICKLINE(D3>0,0.1,0,2,0),COLORWHITE;

 

556555119.jpg

556555119.jpg

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则