通达信益盟操盘手经典指标源码

[复制链接]
查看815 | 回复0 | 2021-8-21 06:30:59 | 显示全部楼层 |阅读模式

以下是通达信益盟操盘手经典指标源码(无源码的请下载附件导入)

益盟操盘手经典指标源码,希望觉得有用的人拿去吧
ABJB
按部就班
N(1,100,5)
现价:C;
顶部: cost(95) ,colorffff33;
卖出: cost(75) ,colorgreen;
买入: cost(30) ,colorred;
底部: cost(5) ,colorteal;
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 LTSH
龙腾四海
N(1,100,8)
坐标线:0;20;50;80;100;
 100-100*(HHV(HIGH,5*N)-CLOSE)/(HHV(HIGH,5*N)-LLV(LOW,5*N));
海面:20,COLORGREEN;
海天分界线:50,COLORYELLOW;
天际:80,COLORRED;
————————————————————————
QSDD
趋势顶底
80,COLOR996699;
 20,COLORGREEN;
 10,COLORCC6633,LINETHICK2;
 90,COLOR9966FF,LINETHICK2;
 {
 50,COLORRED;
 FILLRGN(1,20,80),color222222;
 FILLRGN(1,90,100),color000068;
 FILLRGN(1,79,90),color663366;
 FILLRGN(1,10,20),color666600;
 FILLRGN(1, 0,10),color663300;
 }
 A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
 B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
 d:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),linethick2;
长期线:A+100,color9900FF;
短期线:B+100,color888888;
中期线:d+100,coloryellow,linethick2;
 {见顶:(长期线>85 or ref(长期线,1)>85 ) and (cross(中期线,短期线) or cross(ref(中期线,1),ref(短期线,1)) )and cross(长期线,短期线);}
见顶:(ref(中期线,1)>85 and  ref(短期线,1)>85 and ref(长期线,1)>65) and cross(长期线,短期线) ;
顶部区域:(中期线80) and (ref(短期线,1)>95 or ref(短期线,2)>95 ) and 长期线>60 and 短期线<83.5 and 短期线<中期线 and 短期线<长期线+4;
顶部:=filter(顶部区域,4);
 {DRAWICON( 见顶, 108, 2 );}
底部区域:(长期线<12 and 中期线<8 and (短期线<7.2 or ref(短期线,1)<5) and (中期线>ref(中期线,1) or 短期线>ref(短期线,1))) or (长期线<8 and 中期线<7

and 短期线<15 and 短期线>ref(短期线,1)) or (长期线<10 and 中期线<7 and 短期线<1) ;
 stickline( {见顶 or} 顶部,99,103,20,1 ),colorred,linethick2;
 stickline( 底部区域,-4,0,22,0 ),colorgreen;
低位金叉:长期线<15 and ref(长期线,1)<15 and 中期线<18 and 短期线>ref(短期线,1) and cross(短期线,长期线) and 短期线>中期线 and (ref(短期线,1)<5 or

ref(短期线,2)<5 )  and (中期线>=长期线 or ref( 短期线,1)<1 );
 stickline( 低位金叉,0,5,11,0 ),colorred;
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 BDWQ
波段无敌
P1:=0;
 P2:= IF (CLOSE>MA(CLOSE,5),P1+10,P1-10);
 P3:= IF (CLOSE>MA(CLOSE,10),P2+10,P2-10);
 P4:= IF (CLOSE>MA(CLOSE,10),P3+10,P3-10);
 P5:= IF (MA(CLOSE,5)>MA(CLOSE,10),P4+10,P4-10);
 P6:= IF (MA(CLOSE,10)>MA(CLOSE,20),P5+10,P5-10);
 BD:P6;
 STICKLINE(BD>=-50,-50,BD,3,0),COLORGREEN;
 STICKLINE(BD>=-30,-30,BD,3,0),COLORFFFF00;
 STICKLINE(BD>=0,0,BD,3,0),COLORYELLOW;
 STICKLINE(BD<=50 AND BD>=30,30,BD,3,0),COLORRED;
 {STICKLINE(BD<=50 OR BD>=30,30,BD,3,0),COLORRED;}
………………………………………………………………………………
BHLCT
冰火两重天
P1(1,100,16)
 能量:=SQRT(vol)*(((C-(H+L)/2))/((H+L)/2));
平滑能量:=EMA(能量,P1);
能量惯性:EMA(平滑能量,P1) ;
 STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.05),(能量惯性-能量惯性*0.15),3,0), COLOR0000CC;
 STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.2),(能量惯性-能量惯性*0.35),3,0), COLOR0066FF;
 STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.4),(能量惯性-能量惯性*0.55),3,0),COLOR0099FF;
 STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.6),(能量惯性-能量惯性*0.75),3,0), COLOR00CCFF;
 STICKLINE(能量惯性>=0,(能量惯性-能量惯性*0.8),(能量惯性-能量惯性*0.95),3,0), COLOR00FFFF;
 STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.05),(能量惯性-能量惯性*0.15),3,0), COLORFF3300;
 STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.2),(能量惯性-能量惯性*0.35),3,0), COLORFF6600;
 STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.4),(能量惯性-能量惯性*0.55),3,0), COLORFF9900;
 STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.6),(能量惯性-能量惯性*0.75),3,0), COLORFFCC00;
 STICKLINE(能量惯性<0,(能量惯性-能量惯性*0.8),(能量惯性-能量惯性*0.95),3,0), COLORFFFF00;
 ------------------------------------
 cmfx
筹码分析
HSL:=EMA(VOL/CAPITAL,3);
 ZDL:HHV(HSL,240);
 ZXL:LLV(HSL,240);
 XS:=MA(C,33);
锁定筹码:EMA((HSL-ZXL)/ZXL*XS,13);
浮动筹码:EMA((ZDL-HSL)/HSL*XS,13);
力量对比:锁定筹码-浮动筹码 ,COLORSTICK;
------------
dkby
多空博弈
VAR1:=(HHV(HIGH,21)-C)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
 VAR2:=(C-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
 VAR3:=SMA(VAR2,13,8);
高位:90;
低位:0;
多方: SMA(VAR3,13,8),COLORRED;
空方: SMA(VAR1,21,8),COLORGREEN;
中轴:45;
-----------------
mmpp
买卖频谱
 买线:EMA(C,3);
卖线:EMA(SLOPE(C,21)*20+C,55);
买卖差:=买线-卖线;
STICKLINE(买卖差>=0,(买线-买卖差*0.05),(买线-买卖差*0.15),5,0) ,COLOR00FFFF;
 STICKLINE(买卖差>=0,(买线-买卖差*0.2),(买线-买卖差*0.35),5,0) ,COLOR00CCFF;
 STICKLINE(买卖差>=0,(买线-买卖差*0.4),(买线-买卖差*0.55),5,0) ,COLOR0099FF;
 STICKLINE(买卖差>=0,(买线-买卖差*0.6),(买线-买卖差*0.75),5,0) ,COLOR0066FF;
 STICKLINE(买卖差>=0,(买线-买卖差*0.8),(买线-买卖差*0.95),5,0) ,COLOR0000CC;
 STICKLINE(买卖差<0,(卖线+买卖差*0.05),(卖线+买卖差*0.15),5,0) ,COLOR006600;
 STICKLINE(买卖差<0,(卖线+买卖差*0.2),(卖线+买卖差*0.35),5,0) ,COLOR009900;
 STICKLINE(买卖差<0,(卖线+买卖差*0.4),(卖线+买卖差*0.55),5,0) ,COLOR00CC00;
 STICKLINE(买卖差<0,(卖线+买卖差*0.6),(卖线+买卖差*0.75),5,0) ,COLOR00FF00;
 STICKLINE(买卖差<0,(卖线+买卖差*0.8),(卖线+买卖差*0.95),5,0) ,COLOR66FF00;
------------
zljc
主力进出
MAV:=(C*2+H+L)/4;
 SK:= EMA(MAV,13) - EMA(MAV,34);
 SD := EMA(SK,5);
中轴:0;
空方主力 : (-2*(SK-SD))*3.8,COLORGREEN;
多方主力 : (2*(SK-SD))*3.8,COLORRED;
 --------------------------------------
成本均线
P1 (0, 10000, 5,  1);
 P2 (0, 10000, 13, 1);
 P3 (0, 10000, 34, 1);
 cb1:ema(AMOUNT,P1)/EMA(VOL,P1)*10;
 cb2:ema(amount,P2)/ema(vol,P2)*10;
 cb3:ema(amount,P3)/ema(vol,P3)*10;
 ∞:DMA(C,V/CAPITAL);(这行重要)
--------------------------------------
资金博弈
jgV:=(BIGORDER(1,3)-BIGORDER(2,3));
 dhV:=(BIGORDER(1,2)-BIGORDER(2,2)-BIGORDER(1,3)+BIGORDER(2,3));
 zhV:=(BIGORDER(1,1)-BIGORDER(2,1)-BIGORDER(1,2)+BIGORDER(2,2));
 shV:=(BIGORDER(2,1)-BIGORDER(1,1));
 A1:=MIN((COUNT(ORDER(2),0)),60);
超级资金:EMA(jgV,A1)*A1,COLORMAGENTA;
大户资金:EMA(dhV,A1)*A1,color3399FF ;
中户资金:EMA(zhV,A1)*A1,colorcyan;
散户资金:EMA(shV,A1)*A1,colorgreen;
 0,color333333,PRECIS0,layer7;
超级资金
A1:=MIN((COUNT(ORDER(2),0)),60);
超户:(BIGORDER(1,3)-BIGORDER(2,3)),COLOR3D ;
累计:EMA(超户,A1)*A1,COLORMAGENTA;
均值:MA(累计,10),colorwhite;
大户资金
A1:=MIN((COUNT(ORDER(2),0)),60);
大户:(BIGORDER(1,2)-BIGORDER(2,2)-BIGORDER(1,3)+BIGORDER(2,3)),COLOR3D ;
累计:EMA(大户,A1)*A1,color3399FF;
均值:MA(累计,10),colorwhite;
中户资金
A1:=MIN((COUNT(ORDER(2),0)),60);
中户:(BIGORDER(1,1)-BIGORDER(2,1)-BIGORDER(1,2)+BIGORDER(2,2)),COLOR3D ;
累计:EMA(中户,A1)*A1,colorcyan;
均值:MA(累计,10),colorwhite;
散户资金
A1:=MIN((COUNT(ORDER(2),0)),60);
散户:(BIGORDER(2,1)-BIGORDER(1,1))*vol/capital,COLOR3D ;
累计:EMA(散户,A1)*A1,colorgreen;
均值:MA(累计,10),colorwhite;

750199633.jpg

750199633.jpg

75011449.rar (2.31 KB, 下载次数: 3, 售价: 4 金钱)
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则